Clicky

  • Welcome to P2P Lending / NFT Lending Forum.
 

ETH.LOAN

News:

This was the original Lend Academy peer-to-peer lending forum, since forensically restored by deBanked and now reintroduced to eth.loan.

To restore access to your user account, email [email protected]. We apologize for errors you may experience during the recovery.

Main Menu
NEW LOANS:   | 338.eth 0.000 Ξ | ludicolo.eth 0.200 Ξ | ludicolo.eth 0.200 Ξ | ALL

Invalid API Response

Started by Peter, April 12, 2016, 11:00:00 PM

Previous topic - Next topic

compuatt

Running the latest version on PLS. 

When I run "browse notes" or when PLS runs automatically, the log shows "Invalid API Response."  No notes are purchased when PLS runs and when I "browse notes," PLS no longer lists available notes.  It just won't complete "browse notes."

I have uninstalled and reinstalled PLS.  I've rebooted.

Any ideas?

sociallender

Thanks for the heads up.  I am not sure what is going on.  It looks like LC API is not sending back a valid API response. I just ran a quick test of their API manually and the payload is empty:

[1] "{"asOfDate":"2016-03-09T17:12:33.794-08:00"}"
[1] "{"asOfDate":"2016-03-09T17:12:34.898-08:00"}"
[1] "{"asOfDate":"2016-03-09T17:12:36.114-08:00"}"
[1] "{"asOfDate":"2016-03-09T17:12:36.832-08:00"}"
[1] "{"asOfDate":"2016-03-09T17:12:37.915-08:00"}"
[1] "{"asOfDate":"2016-03-09T17:12:38.874-08:00"}"
[1] "{"asOfDate":"2016-03-09T17:12:39.835-08:00"}"
[1] "{"asOfDate":"2016-03-09T17:12:40.873-08:00"}"

Each of the above JSON API responses should have loan data included in the response.  PLS does basic data integrity checks to make sure the API response is valid.  Obviously, the response doesn't contain any loan data so it flags as an invalid response.  I am not sure when it started but hopefully LC resolves.  Unfortunately, I am traveling at the moment and can't have a deeper look.   

jheizer

Just a heads up its not you.  Requests for new loans only is failing here as well via my application.

TravelingPennies

Thanks for sharing.  Hopefully LC fixes it soon https://forum.lendacademy.com/Smileys/default/shocked.gif" alt=":o" title="Shocked" class="smiley" />

TravelingPennies

Thanks for the quick responses.  I'm rather technically capable so my brain was multitasking troubleshooting next steps in the background.  Now my brain can rest knowing the problem is not on my end. 

If misery loves company, I seem to have it with this issue.  https://forum.lendacademy.com/Smileys/default/wink.gif" alt=";)" title="Wink" class="smiley" />

TravelingPennies

Second day of "Invalid API Response" error messages. 

Is everyone using PLS down?  Anybody have any information on when the issue is expected to be fixed?

TravelingPennies

LC is working again.  I found 39 loans on the drop this morning.

TravelingPennies

Thank you.  Will check tonight when I get home from work. 

TravelingPennies

It bought a note just now.  All good.   https://forum.lendacademy.com/Smileys/default/smiley.gif" alt=":)" title="Smiley" class="smiley" />

Quackhead

I had this exact issue at 2pm and 6pm today. Hope lending club get this addressed... again.
Wonderful program BTW https://forum.lendacademy.com/Smileys/default/smiley.gif" alt=":)" title="Smiley" class="smiley" />

Fred93


JuP8

I'm having the same issue.

TravelingPennies

Still not working at of 9AM Friday. 

Anybody have any information on when a fix might be in place?

Rob L

The 9am drop just now worked okay for me (not using PLS) but a roll-your-own.

Code: [Select]

TravelingPennies

Seems ok the last few drops.

NEW LOANS:   | 338.eth 0.000 Ξ | ludicolo.eth 0.200 Ξ | ludicolo.eth 0.200 Ξ | ALL